AIM/CP upgrade to version 11.6

As per detected vulnerability in AIM ( Credential Providers ) and the remediation to upgrade AIM agents.

(CyberArk Security Bulletin CA20-15 (force.com))

When we tested it worked with reverse compatibility where AIM agent V11+ works with old driver as well without making any app level changes.

Question: Do we Need to update the application Driver with new driver information ( com.cyberark.jdbc.ASCPDriver) ? do you see any issues concerns/ JDBC connection pools in having higher version of Agent/Jar files but apps still using the same old proxy Drivers com.cyberark.aim.v550.tomcat.ASCPDriver ?