SSL Error while initializing Conjur CLI - Make sure Conjur's root certificate is trusted in this machine

Hello Everyone,

Wanted to check if someone has came across this error and troubleshooted it.
When I am trying to initialize Conjur CLI, I am getting the error in the screenshot.
“Failed to execute command. Reason: SSL Error. Make sure Conjur server’s root certificate is trusted in this machine. If this problem continues, visit docs for more help”

I also checked that the Conjur server’s root server is trusted on this machine, as shown in the screenshot too.

Please assist if there is any idea to troubleshoot it.


What version of the CLI are you using? You can check with conjur --version.

it’s Conjur CLI version 7.1.0

Firstly, we’d recommend you try to upgrade to version 8.x of the CLI. You can find the latest releases here.

In the meantime, this may be due to an issue in the v7.x CLI with handling of certificates not in the root/system trust store. Can you try running ./conjur init --self-signed?

After upgrading to v8.x of the CLI, the error is gone.
Thanks a lot :slight_smile:

Another question:
I have enabled ‘authn-jwt/dev’ authenticator, but in the info end point, it’s still not showing up as enabled, just configured. I have tried to figure out this, but as of now no luck. Any suggestions?

Glad that fixed your issue!

Regarding the JWT authenticator, please make sure you’ve followed all the steps in the documentation for configuring the authenticator. In particular make sure you’ve completed Step 2 - Populate the policy variables.