Policy Owner Update

Good Morning,

I am testing a few things in my lab and I noticed that if I create a policy without an

  • !policy
    id: blah

it will default to the admin user. I am not able to update this with editing the yml file and adding an owner.

  • !policy
    id: blah
    owner: !user Tom

I can see I can change it with a “conjur policy load --replace” but I am wondering if there is an easier way?

Thank you,
Logan Zellem

Hi Logan,

The owner is set on a resource only upon creation, so the only way to change the owner is to load the policy with replace or to explicitly delete the resource and recreate it. I advise as a best practice to always load policy with the --replace option.


Hi Nathan,

Thank you!

-Logan Zellem

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.