Central Credential Provider - installation

please close this

inb4close: Here’s a video I put together that’s available on YouTube for anyone looking for CCP Installation assistance!

(K, now you can lock this thread.)


Hi @joe.garcia we have setup CCP and AIM webservice. Also set up the Credential providers for windows on the local machine of some developers and which are working successfully to access the secrets via rest API from their codes. This time I have some developers who are using mac devices. I tried to set up the Mac Credential Provider (V 9.60) on their machines. I used SSL to secure the connection between Mac Credential Provider and CCP webservice. When they tried to access the secrets i see it is failing with the “405 method not found” error on the CCP server IIS logs. i have been receiving the POST request for REST API on the IIS logs. Do you have recommendations where should i take troubleshooting actions here?

The Mac Credential Provider uses a GET request to the CCP Web Service to retrieve the credentials. You would see a GET request for REST API on the IIS logs, not POST. If your developers are sending a POST request, then 405 Method Not Found/Allowed would be returned.

1 Like